<!DOCTYPE html> <html lang="en-US"> <head> <script>var pb_global={pageName:"article-template",pageId:"rHJ9vP1Xz0ktKr",contextPath:"/pb",isAdmin:false,layoutEngineName:"",environment:"prod",resourceToken:"",_website:"wbrc"};</script> <script>window.serviceCallbacks=[];window.pageBuilder=window.pageBuilder||{};window.pageBuilder.featureLoaded=function(el){if(window.services.asyncFeatureCallback)window.services.asyncFeatureCallback(el);else window.serviceCallbacks.push(function(){window.services.asyncFeatureCallback(el)})};</script> <script>(function(){if(window.BOOMR&&window.BOOMR.version)return;var dom,doc,where,iframe=document.createElement("iframe"),win=window;function boomerangSaveLoadTime(e){win.BOOMR_onload=e&&e.timeStamp||(new Date).getTime()}if(win.addEventListener)win.addEventListener("load",boomerangSaveLoadTime,false);else if(win.attachEvent)win.attachEvent("onload",boomerangSaveLoadTime);iframe.src="javascript:false";iframe.title="";iframe.role="presentation";(iframe.frameElement||iframe).style.cssText="width:0;height:0;border:0;display:none;";
where=document.getElementsByTagName("script")[0];where.parentNode.insertBefore(iframe,where);try{doc=iframe.contentWindow.document}catch(e){dom=document.domain;iframe.src="javascript:var d\x3ddocument.open();d.domain\x3d'"+dom+"';void(0);";doc=iframe.contentWindow.document}doc.open()._l=function(){var js=this.createElement("script");if(dom)this.domain=dom;js.id="boomr-if-as";js.src="https://c.go-mpulse.net/boomerang/"+"XPXCW-DAMJV-5VCNY-NSGAA-ZZ4G2";BOOMR_lstart=(new Date).getTime();this.body.appendChild(js)};
doc.write('\x3cbody onload\x3d"document._l();"\x3e');doc.close()})();</script> <script>
  const addZeroPad = function(num) {
    num = Math.abs(num)
    num = num.toString()
    if (num.length === 1) {
      num = '0' + num
    }
    return num
  }

  const getTimezoneOffset = function() {
    const offset = -new Date().getTimezoneOffset() / 60
    const sign = offset < 0 ? '-' : '+'
    return sign + addZeroPad(offset) + ':00'
  }
</script> <script>
  var RCdataLayer = [{
    "adTarget": "wbrc/web/news/top-story",
    "authors": [
                  
                    {
                      "_id": "caroline-klapp",
                      "name": "Caroline Klapp",
                      "type": "author"
                    },
                  
                    {
                      "_id": "margo-gray",
                      "name": "Margo Gray",
                      "type": "author"
                    },
                  
                    {
                      "_id": "wade-smith",
                      "name": "Wade Smith",
                      "type": "author"
                    },
                  
                    {
                      "_id": "william-mclain",
                      "name": "William McLain",
                      "type": "author"
                    },
                  
                ],
    "canonicalUrl": "/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/",
    "contentId": "XYSCHHIYRZCCBEHLCP6KPPPKZI",
    "contentName": "Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville",
    "contentOwner": "waff",
    "contentTags":  [
                  
                ],
    "contentType": "story",
    "datePublished": "2020-05-20T11:32:39.135Z",
    "description": "Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony.",
    "distributorCategory": "staff",
    "distributorMode": "reference_denormalized",
    "distributorName": "Gray TV Stations",
    "distributorReferenceId": "dee592ee-659e-4038-a289-0bfe818887ca",
    "distributorSubCategory": "gray-original-content",
    "hasVideo": "false",
    "metaDescription": "Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony.",
    "platformName": "Arc Feature Pack",
    "primarySection": 
                        
                        
                          
                          {
                            "name": "Top Story",
                            "_id": "/news/top-story",
                            "path": "/news/top-story",
                          }
                        
                      ,
    "publishedDay": "20",
    "publishedMonth": "05",
    "publishedYear": "2020",
    "stationName": "wbrc",
    "timezoneOffset": getTimezoneOffset(),
    "userAgent": navigator.userAgent,
    "userId": "",
    "userTimezone": Intl.DateTimeFormat().resolvedOptions().timeZone,
    "userTimezoneTimestamp": new Date()
  }]

</script> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!="dataLayer"?"\x26l\x3d"+l:"";j.async=true;j.src="https://www.googletagmanager.com/gtm.js?id\x3d"+i+dl;f.parentNode.insertBefore(j,f)})(window,document,"script","RCdataLayer","GTM-M5QQ3JP");</script> <meta http-equiv="X-UA-Compatible" content="IE=edge"/> <meta name="distribution" content="global"/> <meta name="rating" content="general"/> <meta name="viewport" content="width=device-width, minimum-scale=1, initial-scale=1"> <meta charset="UTF-8"/> <meta name="copyright" content="Copyright (c) 2017 "/> <meta name="google-site-verification" content="mlx8jNOulM5FyAWS2LMKiunwM7WIY3Bb7MD8FY5L4rU"/> <title>Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville</title> <meta name="keywords" content="Little, Richard, Penniman, Wednesday, funeral, burial, services, Oakwood, Memorial, Gardens"> <meta name="news_keywords" content="Little, Richard, Penniman, Wednesday, funeral, burial, services, Oakwood, Memorial, Gardens"/> <meta name="date" content="2020-05-20T18:11:23.479Z"/> <meta itemprop="description" name="description" content="Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony."/> <meta name="robots" content="index,follow,noarchive"/> <meta name="googlebot" content="index"/> <meta name="googlebot-news" content="index"/> <link rel="canonical" href="https://www.wbrc.com/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/"> <meta name="twitter:title" content="Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville"/> <meta name="twitter:image" content="https://www.wbrc.com/resizer/8POO3crOJNqIcs4wBbeQJYNuvYM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png"/> <meta name="twitter:card" content="summary_large_image"> <meta name="twitter:description" content="Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony."/> <meta name="twitter:site" content="@WBRCnews"/> <meta name="twitter:creator" content="@WBRCnews"> <meta property="og:url" content="https://www.wbrc.com/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/"/> <meta property="og:title" content="Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville"/> <meta itemprop="image" property="og:image" content="https://www.wbrc.com/resizer/8POO3crOJNqIcs4wBbeQJYNuvYM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png"/> <meta property="og:description" content="Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony."/> <meta property="og:locale" content="en_US"/> <meta property="og:site_name" content="https://www.wbrc.com"/> <meta property="og:type" content="article"/> <meta property="fb:app_id" content="201549519904955"/> <meta property="fb:pages" content="261724115292"/> <meta property="fb:admins" content="644426401"/> <meta name="burst" content="WBRC"/> <meta property="article:publisher" content="https://www.facebook.com/WBRCnews/"> <link rel="amphtml" href="/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/?outputType=amp"> <meta name="author" content="Caroline Klapp, Margo Gray, Wade Smith, William McLain"> <script data-schema="NewsArticle" type="application/ld+json">
      {
        "@context": "http://schema.org",
        "@type": "NewsArticle",
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": ""
        },
        "headline": "Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville",
        
        "image": {
          "@type": "ImageObject",
          "url": "https://www.wbrc.com/resizer/8POO3crOJNqIcs4wBbeQJYNuvYM=/1200x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png",
          "height": 1080.0,
          "width": 1200
        },
        
        "datePublished": "2020-05-20T19:40:35.446Z",
        "dateModified": "2020-05-20T18:11:23.479Z",
        "articleBody": "HUNTSVILLE, Ala. (WAFF) - A music icon was laid to rest in the Rocket City on Wednesday.Little Richard laid to rest at OakwoodLittle Richard, born Richard Penniman, passed away in Tennessee on May 9. Outside of music, his faith was his passion. He studied that faith in the Tennessee Valley at Oakwood University.Little Richard was buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony.Oakwood allowed for the public to come and pay their respects as the funeral procession happened. They asked people to park at the business and technology center at Wynn Drive and Adventist Boulevard.People also set up at the Oakwood Farms Market across the road from the main campus entrance at Adventist and Sparkman.Little Richard performsIt is impossible to understate just how big of an influence Little Richard was on the history of music and rock &amp;amp; roll. Without him, artists like the Beatles, Rolling Stones, James Brown, and Michael Jackson may never have had the levels of success they found following Richard.He was one of the first black artists to find success with fans of all backgrounds and he was in the very first class inducted into the rock and roll hall of fame.WAFF talked with Oakwood University President Dr. Leslie Pollard on Tuesday. Pollard says he has a lot of respect for Richard, and the way he cared for the people in his life will always be remembered.“If he knew you, he knew you and you’d always be his friend, so he never forgot the people in his life” said Pollard.“Pat Boone took one of this songs, said he never sang songs like that, said it was sick, he called it all kinds of names then he sang it and it became a hit for him. Richard never retaliated. He said well, his singing made it more popular, I mean, that was Richard!”Little Richard’s band mates came from various parts of the country to pay tribute to the legendary rock and roller.Some of his band mates described Richard as a “father figure” as many had learned lessons about life and music over more than a 30-year career.Richard Wayne PennimanMillions of music fans knew Little Richard for hits such as “Tutti Frutti,” “Long Tall Sally” and “Good Golly, Miss Molly,” all sung with the gusto of a gospel singer to a rollicking rock beat while wearing his signature pompadour hairstyle and pencil-thin mascara mustache.But his family knew and loved him as Richard – a husband, father, brother, mentor and dedicated Christian.The rock legend was born in Macon, Ga. in 1932. He was the third oldest of 12 children, seven of whom are still living. The surviving siblings are Leva Penniman, Gail Penniman, Freka Merrell, Walter Penniman, Peyton Penniman, Elaine Harmison and Peggy Connor.Copyright 2020 WAFF. All rights reserved.",
        "author": [
          
            
              
                {
                  "@type": "Person",
                  "name": "Caroline Klapp"
                },
              
                {
                  "@type": "Person",
                  "name": "Margo Gray"
                },
              
                {
                  "@type": "Person",
                  "name": "Wade Smith"
                },
              
                {
                  "@type": "Person",
                  "name": "William McLain"
                }
              
            
            
          
        ],
         "publisher": {
        "@type": "Organization",
        "name": "WBRC",
        "logo": {
          "@type": "ImageObject",
          "url": "https://www.wbrc.com/pb/resources/images/rm_icons/wbrc-icon.png?token=123",
          "width": 467,
          "height": 60
        }
      }
        },
        // will be empty for branded publishing
        "description": "Little Richard will be buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony."
      }
    </script> <script data-schema="Organization" type="application/ld+json">
      {
        "name": "WBRC",
        "url": "https://www.wbrc.com",
        "logo": "https://www.wbrc.com/pb/resources/images/rm_icons/wbrc-icon.png?token=123",
        "@type": "Organization",
        
          "sameAs": [ "https://www.facebook.com/WBRCnews/" ],
        
        "@context": "http://schema.org"
      }
    </script> <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.2.0/css/all.css" integrity="sha384-hWVjflwFxL6sNzntih27bfxkr27PmbbK/iSvJ+a4+0owXq79v+lsFkW54bOGbiDQ" crossorigin="anonymous"> <link href="//cdn-images.mailchimp.com/embedcode/horizontal-slim-10_7.css" rel="stylesheet" type="text/css"> <link href="https://fonts.googleapis.com/css?family=Oswald:400,600,700|PT+Serif:400,400i,700i" rel="stylesheet"> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <style>.logo{background-image:url(/pb/resources/images/wbrc-logo.svg?v=90)}.logo.logo-footer{background-image:url(/pb/resources/images/footer_icons/wbrc-logo.svg?v=90)}</style> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-framework96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-features96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <link href="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-services96cfbfc61ff908bdad44.css?v=90" rel="stylesheet"/> <script src="/pb/gr/c/default/rHJ9vP1Xz0ktKr/arcAdsJS/cdbd7d78da.js?v=90"></script> <script>
  const arcAds = new ArcAds({
    dfp: {
      id: '63316753'
    }
  });
  window.arcAds = arcAds;
</script> <script src="//cdn.connatix.com/min/connatix.renderer.infeed.min.js" data-connatix-token="6df7cd61-4ba7-4986-a10f-79460227667e" async></script> </head> <body> <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M5QQ3JP" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> </head> <body> <div id="pb-root" class=""><a class="skip-link" href="#header">Skip to content</a> <section id="nav" class="relative zindex-higher col"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-sales-nav" id="faYVSr1Xz0ktKr"> <div id="sales-nav" class="background-grey-minimal visible-lg"> <div class="container"> <ul class="list-unstyled flex-container-row padded padded-top padded-bottom padded-xs"> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wbrc.com/business/legal/lawcall/" class="color-grey-dark">LawCall</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.wbrc.com/asktheexpert/" class="color-grey-dark">Ask the Expert</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wbrc.com/community/rising-star/" class="color-grey-dark">Rising Star</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.wbrc.com/wbrc-contests/" class="color-grey-dark">Contests</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="http://www.wbrc.com/businessbuilder/" class="color-grey-dark">Business Builder</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="https://www.wbrc.com/2020/04/03/class-we-celebrate-you/" class="color-grey-dark">Class of 2020: A Picture Perfect Graduation</a></li> <li class="padded padded-right padded-md flex-shrink"><a href="" class="color-grey-dark"></a></li> </ul> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-test-html-box" id="f0aKfloXz0ktKr"> <style>.pb-f-article-body .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 200px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}.pb-f-article-body .card .img-container.width-full,.pb-f-article-header .card .img-container.width-full{background-color:#f9f9f9}.pb-f-article-header .card .img-container.width-full img.width-full{display:block;max-height:calc(100vh - 150px);width:auto;max-width:100%;margin-left:auto;margin-right:auto}</style> </div> <div class="pb-container"> </div> </section> <header id="sticky-nav" class="sticky zindex-higher col"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-global-navigation-bar" id="f0ExsO8Xz0ktKr"> <div id="app-bar" class="app-bar card padded padded-sm padded-top padded-bottom width-full" role="navigation"> <div class="justify-space-between align-items-center flex-container-row relative app-bar-inner container"> <button id="app-bar-topics-button" name="topicsMenu" class="app-button justify-center flex-container-row no-border" data-role="open-tray" data-tray="topics"> <span class="fa fa-2x fa-bars" aria-hidden="true"></span> </button> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.wbrc.com"> <div class="logo logo-slim"></div> </a> </div> <div class="app-bar-top-container flex-3 flex-container-row relative spaced spaced-sm spaced-left spaced-right hidden-sm"> <ul id="app-bar-top-menu" class="list-unstyled flex-container-row topics-list uppercase align-items-center flex-shrink"> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/news" class="">News</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/live" class="">Live</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/weather" class="">First Alert Weather</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/sports" class="">Sports</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="http://www.magiccityweekend.com/" class="">Magic City Weekend</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="/programming/good-day" class="">Good Day Alabama</a> </h3> </li> <li class="spaced spaced-right spaced-lg li-1"> <h3> <a href="https://www.graytvlocal.com/market/central-al" class="">Open for Business</a> </h3> </li> </ul> </div> <div class="search-box-container search-box flex flex-container-row align-items-center justify-end"> <div class="search-box-inner"> <form class="search search-expandable-form small" action="/search/" method="GET"> <input type="checkbox" class="checkbox" name="search-action" id="search-action"/> <label class="magnifying-glass" for="search-action"> <i class="search-button fa fa-search"></i> <i class="close-button fa fa-times"></i> </label> <input type="text" class="search-text-field" id="expandable-search" name="q" placeholder="Search..."/> </form> </div> </div> </div> </div> <div class="app-bar-tray" data-role="tray" data-tray="topics"> <nav [class]="visible == true ? 'tray left-0 hidden width-full zindex-high tray-open visible' : 'tray left-0 hidden width-full zindex-high hidden'" class="tray left-0 hidden width-full zindex-high"> <div class="topics-tray tray-contents card card-dark padded padded-bottom padded-md"> <div class="tray-contents-inner container" tabindex="0"> <div class="five-hundred-screen-height"> <div class="container"> <div class="flex-grid"> <div class="tray-section tray-section-1 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/homepage" class="color-white">Home</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wbrc.com/live" class="color-white">Watch Live!</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.wbrc.com/community/user-content/" class="color-white">Share Your Pics</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="http://www.wbrc.com/call-for-action/" class="color-white">Call for Action</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.wbrc.com/stay-connected-apps/" class="color-white">Streaming Apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="http://www.wbrc.com/apps/" class="color-white">Download WBRC apps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.wbrc.com/wbrc-podcasts/" class="color-white">WBRC Podcast Network</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="http://www.wbrc.com/video-gallery/" class="color-white">Latest Videos</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.wbrc.com/newsletter/" class="color-white">Sign Up for Our Newsletter</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="https://www.wbrc.com/wbrc-contests/" class="color-white">Contests</a> </div> </div> </div> </div> <div class="tray-section tray-section-2 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/news" class="color-white">News</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.wbrc.com/health/coronavirus/" class="color-white">Coronavirus: Working Our Way Back</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/news/investigate" class="color-white">On Your Side Investigations</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.wbrc.com/2020/03/16/help-restaurants-survive-covid-locations-offering-no-contact-pick-up/" class="color-white">Restaurants are open</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="https://www.wbrc.com/2020/01/13/homicide-maps-north-central-alabama/" class="color-white">Homicide Maps</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/news/national" class="color-white">National</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.wbrc.com/news/shelby-county/" class="color-white">Covering Shelby County</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/news/west-alabama" class="color-white">West Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.wbrc.com/politics/election-results/" class="color-white">Election Results</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="/news/central-alabama" class="color-white">Central Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-12"> <a href="/news/east-alabama" class="color-white">East Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-13"> <a href="/politics" class="color-white">Politics</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-14"> <a href="/news/education" class="color-white">Education</a> </div> </div> </div> </div> <div class="tray-section tray-section-3 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/weather" class="color-white">First Alert Weather</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="https://www.wbrc.com/2020/02/10/how-program-your-weather-radio/" class="color-white">How to Program Weather Radio</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="https://www.wbrc.com/community/user-content/" class="color-white">Share Your Pics</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/weather/cams" class="color-white">SkyVision</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/weather/behind-the-front" class="color-white">Behind the Front</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/weather/closings" class="color-white">Closings</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="https://www.wbrc.com/2020/01/16/wbrc-first-alert-severe-weather-policy/" class="color-white">WBRC First Alert Weather Policy</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="http://www.wbrc.com/weather/hurricane/" class="color-white">Hurricane Central</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="http://www.wbrc.com/iheart-radio-stations/" class="color-white">iHeart Radio Stations</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-11"> <a href="/willytheweatherkid/" class="color-white">Willy the Weather Kid</a> </div> </div> </div> </div> <div class="tray-section tray-section-4 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/sports" class="color-white">Sports</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/sports/ncaa/alabama" class="color-white">Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/sports/ncaa/auburn" class="color-white">Auburn</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/sports/ncaa/uab" class="color-white">UAB</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/sports/ncaa/samford" class="color-white">Samford</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/sports/ncaa/jsu" class="color-white">JSU</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/sports/high-school/football/" class="color-white">Sideline</a> </div> </div> </div> </div> <div class="tray-section tray-section-5 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming/good-day" class="color-white">Good Day Alabama</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/food/recipe" class="color-white">Recipes</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/weather/mickeys-weather-kids" class="color-white">Mickey's Weather Kids</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="http://www.whatthetech.tv/" class="color-white">What the Tech</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/cookbook" class="color-white">Good Day Alabama Cookbook</a> </div> </div> </div> </div> <div class="tray-section tray-section-6 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/community" class="color-white">Community</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.magiccityweekend.com/" class="color-white">Magic City Weekend</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/community/rising-star/" class="color-white">Rising Star</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="/community/heart-of-alabama" class="color-white">Heart of Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="/community/absolutely-alabama" class="color-white">Absolutely Alabama</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="/community/calendar" class="color-white">Calendar</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="/community/user-content" class="color-white">Share Your Pics</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="/community/doing-good" class="color-white">Doing Good</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.graytvlocal.com/market/central-al" class="color-white">Open for Business</a> </div> </div> </div> </div> <div class="tray-section tray-section-7 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/traffic" class="color-white">Traffic</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/traffic/59-20-shutdown" class="color-white">59/20 Shutdown</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/traffic/gas-prices" class="color-white">Gas Prices</a> </div> </div> </div> </div> <div class="tray-section tray-section-8 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/programming" class="color-white">TV</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/programming/schedule" class="color-white">Programming Schedule</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.fox.com/" class="color-white">FOX TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://www.bouncetv.com/" class="color-white">Bounce TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.grittv.com/" class="color-white">GRIT TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="http://www.laff.com/" class="color-white">Laff TV</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-8"> <a href="http://www.rightthisminute.com/" class="color-white">Right This Minute</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-9"> <a href="http://www.circleallaccess.com" class="color-white">Circle - Country Music & Lifestyle</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-10"> <a href="https://www.fullcourtgreta.com/" class="color-white">Full Court Press with Greta Van Susteren</a> </div> </div> </div> </div> <div class="tray-section tray-section-9 tray-section-odd justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/about-us" class="color-white">About Us</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="http://www.wbrc.com/about-us" class="color-white">Contact Us</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="http://www.wbrc.com/about-us/meet-the-team/" class="color-white">Meet the Team</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://gray.tv/careers#currentopenings" class="color-white">Careers at WBRC FOX6</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.wbrc.com/story/10551313/wbrc-fox6-news-internship-program" class="color-white">Internship Program</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-7"> <a href="http://www.wbrc.com/story/10551172/wbrc-fox6-news-station-history" class="color-white">Station History</a> </div> </div> </div> </div> <div class="tray-section tray-section-10 tray-section-even justify-start uppercase links min-width-25 padded padded-md padded-right padded-left spaced spaced-xl spaced-top "> <div class="tray-section spaced spaced-md spaced-left spaced-right li-1"> <h3 class="spaced spaced-xs spaced-bottom padded padded-xs padded-right padded-left"> <a href="/business" class="color-white">Business</a> </h3> <div class="tray-section-children flex-grid flex-wrap no-transform padded padded-sm padded-bottom g-ulc-1 "> <div class="tray-section-child padded padded-xs padded-right padded-left li-3"> <a href="/business/legal/lawcall" class="color-white">LawCall</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-4"> <a href="/business/money" class="color-white">Money Matters</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-5"> <a href="https://a.pgtb.me/LFxnTt" class="color-white">Ask the Expert</a> </div> <div class="tray-section-child padded padded-xs padded-right padded-left li-6"> <a href="http://www.wbrc.com/businessbuilder/" class="color-white">Business Builder</a> </div> </div> </div> </div> </div> </div> </div> </div> </div> </nav> </div> </div> </div> </header> <section id="top" class="width-full"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-breaking-news" id="f0MEpCZXz0ktKr"> <div id="breaking-news-wrapper" class="breaking-news-wrapper" data-feature-name="breaking-news-bar" data-feature-grouping=".pb-f-global-breaking-news" data-page-uri="/fragment-wbrc-breaking/" data-url="/pb/api/v2/render/feature" data-website="wbrc" data-view-unpublished=""> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-weather-weather-alerts" id="fZgFpz1Xz0ktKr"> <div id="weather-alerts-wrapper" class="weather-alerts-wrapper" data-feature-name="weather-alerts-bar" data-feature-grouping=".pb-f-weather-weather-alerts" data-page-uri="/wbrc-weather-alerts/" data-url="/pb/api/v2/render/feature" data-website="wbrc"> <div data-href="/pb/api/v2/render/feature"> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="fOcnHR1Xz0ktKr"> <div id="ad1579-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1579" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1579",slotName:"wbrc/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"XYSCHHIYRZCCBEHLCP6KPPPKZI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},
{lazyload:true})});</script> </div> </div> </div> <div class="pb-container"> </div> </section> <div class="container flex-grid"> <article id="content-well" class="col desktop-8 tablet-12 mobile-12"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-article-header" id="f0G8x4vXz0ktKr"> <div class="card spaced card-article width-full spaced-bottom spaced-xs"> <div class="text-align-left card-content"> <ul class="tag-list-wrapper list-unstyled flex-container-row text-align-left uppercase unstyled-link spaced spaced-top spaced-sm call-to-action bold"> <li class=""> <a class="tag unstyled-link call-to-action uppercase bold unstyled-link tag-first" href="https://www.wbrc.com/news"> News </a> </li> </ul> <h1 class="spaced spaced-xs spaced-top spaced-bottom">Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville</h1> <h2 class="spaced spaced-xs spaced-top"></h2> </div> <div class="spaced spaced-top spaced-sm"> <div class="card-content"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <img class="width-full " alt="Rock and roll legend Little Richard remembered, laid to rest Wednesday in Huntsville" src="https://www.wbrc.com/resizer/ECLoSTao1ggtyAVHSNeYLEqcx28=/1200x600/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png"/> </div> <div class="container"> <figcaption class="caption-text spaced flex-container-row justify-space-between card card-article"> Richard Wayne Penniman (Source: Oakwood University) </figcaption> </div> </figure> </div> </div> </div> </div> <div class="flex-grid flex-container-row flex-mobile-column col col-no-side-gutter pb-layout-item pb-chain pb-c-article-double-chain full" id="c0qBKcXXz0ktKr"> <section id="article-sharebar" class="col col-no-gutter desktop-1 visible-lg spaced spaced-top spaced-sm"> <div class="flex flex-container-row sticky"> <span class="sharebar app-bar-share sharebar flex-container-column text-align-right"> <button class="social-icon spaced spaced-top spaced-sm" aria-label="share on twitter" name="twitter" onclick="window.open( 'https://twitter.com/intent/tweet?text=Rock+and+roll+legend+Little+Richard+remembered%2C+laid+to+rest+Wednesday+in+Huntsville&amp;url=https%3A%2F%2Fwww.wbrc.com%2F2020%2F05%2F20%2Frock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville%2F', 'share_popup', 'height=500,width=650' ); return false;" role="button" data-arctrack="socialShareTwtr" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-twitter social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <button class="social-icon spaced spaced-top spaced-sm" name="facebook" aria-label="share on facebook" onclick="window.open( 'https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wbrc.com%2F2020%2F05%2F20%2Frock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville%2F&amp;title=Rock+and+roll+legend+Little+Richard+remembered%2C+laid+to+rest+Wednesday+in+Huntsville', 'share_popup', 'height=500,width=650' ); return false;" data-arctrack="socialShareFb" data-referrer="" target="_blank" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="fab fa-facebook-f social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> <a href="mailto:?subject=Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville&amp;body=Read%20more%20on%20Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville%20at%20https%3A%2F%2Fwww.wbrc.com%2F2020%2F05%2F20%2Frock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville%2F"> <button class="social-icon spaced spaced-top spaced-sm" role="button" aria-label="share story via email" data-arctrack="socialShareEmail" data-referrer="" rel="noopener noreferrer"> <span class="fa-stack fa-lg"> <i class="fa fa-circle fa-stack-2x"></i> <i class="far fa-envelope social-logo icon-light fa-stack-1x icon-light"></i> </span> </button> </a> </span> </div> </section> <section class="col col-no-gutter desktop-11 tablet-12 mobile-12 spaced spaced-top spaced-sm"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-byline" id="f0z3yJ5Xz0ktKr"> <div class="card"> <div class="byline spaced spaced-bottom spaced-md card-content display-inline"> By <a class="color-blue hover-link" href="/authors/caroline-klapp/"> <span class="font-bold ">Caroline Klapp</span></a>, <span class="font-bold"></span> <a class="color-blue hover-link" href="/authors/margo-gray/"> <span class="font-bold ">Margo Gray</span></a>, <span class="font-bold"></span> <a class="color-blue hover-link" href="/authors/wade-smith/"> <span class="font-bold ">Wade Smith</span></a>, <span class="font-bold"></span> and <a class="color-blue hover-link" href="/authors/william-mclain/"> <span class="font-bold ">William McLain</span></a> <span class="font-bold">|</span> <span class="timestamp"> May 20, 2020 at 6:32 AM CDT - Updated May 20 at 2:40 PM </span> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-article-body" id="f0OiAz6Xz0ktKr"> <div class="collection collection-cards" id="article-body"> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>HUNTSVILLE, Ala. (WAFF) - A music icon was laid to rest in the Rocket City on Wednesday.</p> </div> </div> <div data-type="image" class="card card-pull-right card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Little Richard laid to rest at Oakwood" data-src="https://www.wbrc.com/resizer/X7phhUayShl_1NGh1Vj_eeLiFq8=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/MFC2L62Z6RA4TBGDHTYFF74VEA.jpg" src="https://www.wbrc.com/resizer/3NGw8LqNXBTMuVqx-r4AJYn0lpM=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/MFC2L62Z6RA4TBGDHTYFF74VEA.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Little Richard laid to rest at Oakwood </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p><a href="https://www.waff.com/2020/05/09/rock-legend-little-richard-dies/" target="_blank">Little Richard, born Richard Penniman, passed away in Tennessee on May 9</a>. Outside of music, his faith was his passion. He studied that faith in the Tennessee Valley at Oakwood University.</p> </div> </div> <div data-type="header" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <h3 class="bold"> <b>BURIAL SERVICES</b></h3> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Little Richard was buried Wednesday at the Oakwood University Memorial Gardens Cemetery during a closed ceremony.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Oakwood allowed for the public to come and pay their respects as the funeral procession happened. They asked people to park at the business and technology center at Wynn Drive and Adventist Boulevard.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1263-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1263" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1263",slotName:"wbrc/web/news/top-story/XYSCHHIYRZCCBEHLCP6KPPPKZI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="video" class="card card-captioned collection-item card-embedded-content hidden"> <div class="card-content card-article"> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>People also set up at the Oakwood Farms Market across the road from the main campus entrance at Adventist and Sparkman.</p> </div> </div> <div data-type="header" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <h3 class="bold"> <b>IMPACT ON MUSIC</b></h3> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Little Richard performs" data-src="https://www.wbrc.com/resizer/JkDPD2bVke03GKQCC3qQ0M1wVFc=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/OULN55BBXRAF7A5WIEWHJP2ZNM.jpg" src="https://www.wbrc.com/resizer/ZR64EvfO6p3za2Y1WOBUaLDOlKg=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/OULN55BBXRAF7A5WIEWHJP2ZNM.jpg"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Little Richard performs </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>It is impossible to understate just how big of an influence Little Richard was on the history of music and rock &amp; roll. Without him, artists like the Beatles, Rolling Stones, James Brown, and Michael Jackson may never have had the levels of success they found following Richard.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>He was one of the first black artists to find success with fans of all backgrounds and he was in the very first class inducted into the rock and roll hall of fame.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad938-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad938" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad938",slotName:"wbrc/web/news/top-story/XYSCHHIYRZCCBEHLCP6KPPPKZI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>WAFF talked with Oakwood University President Dr. Leslie Pollard on Tuesday. Pollard says he has a lot of respect for Richard, and the way he cared for the people in his life will always be remembered.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad172-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad172" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad172",slotName:"wbrc/web/news/top-story/XYSCHHIYRZCCBEHLCP6KPPPKZI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“If he knew you, he knew you and you’d always be his friend, so he never forgot the people in his life” said Pollard.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>“Pat Boone took one of this songs, said he never sang songs like that, said it was sick, he called it all kinds of names then he sang it and it became a hit for him. Richard never retaliated. He said well, his singing made it more popular, I mean, that was Richard!”</p> </div> </div> <div data-type="header" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <h3 class="bold"> <b>REMEMBERED BY BANDMATES</b></h3> </div> </div> <div data-type="video" class="card card-captioned collection-item card-embedded-content hidden"> <div class="card-content card-article"> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Little Richard’s band mates came from various parts of the country to pay tribute to the legendary rock and roller.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Some of his band mates described Richard as a “father figure” as many had learned lessons about life and music over more than a 30-year career.</p> <div class="flex-container-column align-items-center hidden-lg spaced spaced-top spaced-sm"> <div id="ad1953-sticky" class="flex-container-column visible-sm"> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad1953" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1953",slotName:"wbrc/web/news/top-story/XYSCHHIYRZCCBEHLCP6KPPPKZI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"mobile",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="header" class="card collection-item card-embedded-content"> <div class="card-content card-article"> <h3 class="bold"> <b>REMEMBERED BY FAMILY</b></h3> </div> </div> <div data-type="image" class="card card-captioned collection-item card-embedded-content"> <div class="card-content card-article"> <figure class=""> <div class="width-full img-container "> <img class="b-lazy width-full " alt="Richard Wayne Penniman" data-src="https://www.wbrc.com/resizer/xwV3bqz6N8xAe_SQ6_rxoZPe_A4=/1400x0/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png" src="https://www.wbrc.com/resizer/l3FxHknDvP64DDgSFuxMAs2uWBk=/0x10/arc-anglerfish-arc2-prod-raycom.s3.amazonaws.com/public/DXIPHEV7CJBODFFH2K6VXG7VZE.png"> </div> <div> <figcaption class="caption-text spaced flex-container-row justify-space-between "> Richard Wayne Penniman (Source: Oakwood University) </figcaption> </div> </figure> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>Millions of music fans knew Little Richard for hits such as “Tutti Frutti,” “Long Tall Sally” and “Good Golly, Miss Molly,” all sung with the gusto of a gospel singer to a rollicking rock beat while wearing his signature pompadour hairstyle and pencil-thin mascara mustache.</p> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>But his family knew and loved him as Richard – a husband, father, brother, mentor and dedicated Christian.</p> <div class="flex-container-column align-items-center hidden-sm spaced spaced-top spaced-sm"> <div id="ad218-sticky" class="flex-container-column "> <div class="flex-container-row justify-center background-grey-minimal padded padded-bottom padded-top padded-sm "> <div id="ad218" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad218",slotName:"wbrc/web/news/top-story/XYSCHHIYRZCCBEHLCP6KPPPKZI",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> <div data-type="text" class="card collection-item "> <div class="card-content card-article"> <p>The rock legend was born in Macon, Ga. in 1932. He was the third oldest of 12 children, seven of whom are still living. The surviving siblings are Leva Penniman, Gail Penniman, Freka Merrell, Walter Penniman, Peyton Penniman, Elaine Harmison and Peggy Connor.</p> </div> </div> <div data-type="text" class="card collection-item card-border-bottom card-border-bottom-thick card-border-bottom-dark"> <div class="card-content card-article"> <p><i>Copyright 2020 WAFF. All rights reserved.</i></p> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-connatix" id="fwaAKx1Xz0ktKr"> <div class="flex-grid ad-connatix spaced spaced-lg spaced-top spaced-bottom "> <div class="col desktop-12 tablet-12 mobile-12"> <div id="connatix-highlights-embed" class="connatix-container box-shadow-light"></div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-outbrain" id="f06efnJXz0ktKr"> <div id="outbrain-article-ad" class=""> <div class="OUTBRAIN" data-widget-id="AR_8" data-src="https://www.wbrc.com/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/" data-ob-template="raycom"> </div> <div class="OUTBRAIN" data-widget-id="AR_9" data-src="https://www.wbrc.com/2020/05/20/rock-roll-legend-little-richard-remembered-laid-rest-wednesday-huntsville/" data-ob-template="raycom"> </div> </div> </div> </section> </div> <div class="pb-container"> </div> </article> <aside id="right-rail" class="col desktop-4 tablet-12 mobile-12 right-rail"> <div class="pb-container"> <div class="wrapper clearfix col pb-feature pb-layout-item pb-f-ads-arcads tablet-6 mobile-12 desktop-12" id="fzMDJM1Xz0ktKr"> <div id="ad305-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad305" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad305",slotName:"wbrc/web/news/top-story",adType:"flex-cube",dimensions:"[[[300, 600], [300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"XYSCHHIYRZCCBEHLCP6KPPPKZI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-6 mobile-12 pb-feature pb-layout-item pb-f-weather-forecast-box" id="f47aum1Xz0ktKr"> <div class="invisible weather-gradient flex-grid color-white pb-weather day" id="weather-forecast-box" data-valid-content="true"> <div id="forecast-box-bg-wrapper" data-current-bg-image="day-partly-cloudy" data-default-location-code="USAL0054" class="weather-item flex pb-weather pb-forecast-box padded padded-md padded-top padded-bottom padded-right padded-left"> <div id="forecast-box-content"> <input type="hidden" id="forecast-box-zip-code" data-url="/pb/api/v2/render/feature/weather/forecast-box" data-feature-grouping=".pb-f-weather-forecast-box" data-website="wbrc" data-location-code="USAL0054" data-language="en" data-content-config-keys='Code,Language' data-content-config-values='USAL0054,en' data-custom-field-keys='spanish' data-custom-field-values=''/> <div class="col spaced spaced-top spaced-sm"> <div class="flex-container-row justify-center"> <div class="spaced spaced-right spaced-lg flex-container-row align-items-center"> <a href="https://www.wbrc.com/weather"> <img class="radar-image" src="https://webpubcontent.raycommedia.com/wbrc/weather/maps/radar/baron/mobile/WBRC_160x120.jpg" width="100%"/> </a> </div> <div class="flex-container-column"> <div class="flex-container-row"> <div class="font-bold temp temp-lg weather-temp temp-lg-forecast-box" data-temp-f="75" data-temp-c="24"> 75</div> <div class="icon spaced spaced-left spaced-md flex-container-row align-items-center"> <img width="40px" height="40px" src="/pb/resources/images/weather/weather-condition-icons/400x400/66_daily_forecast.png" alt="weather icon"/> </div> </div> <div class="spaced spaced-sm spaced-top text-align-center"> <div class="flex-container-column relative"> <div class="text-align-center"> <span class="location font-bold"> Currently in<br/>Birmingham, AL</span> </div> </div> </div> <div class="flex-container-row spaced spaced-top spaced-md justify-center"> <a href="https://www.wbrc.com/weather"> <button class="weather uppercase button button-mini-radius button-transparent button-white-border color-white bold font-sm padded padded-xs padded-left padded-right padded-top padded-bottom"> Full Forecast</button> </a> </div> </div> </div> </div> </div> <div class="flex-container-row justify-center spaced spaced-md spaced-bottom spaced-top font-semi-bold"> <span class="spaced spaced-right spaced-sm">Sponsored By</span> <div id="ad1404-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1404" class="arcad ad-120x30"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1404",slotName:"wbrc/web/weather-widget",adType:"weather-sponsorship",dimensions:"[[[120, 30]], [[120, 30]], [[120, 30]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"weather",cid:""},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:false,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix col desktop-12 tablet-12 mobile-12 pb-feature pb-layout-item pb-f-article-author-bio" id="frRRQ42Xz0ktKr"> <div class="article-author-bio"> <div class="article-author-bio flex-grid flex-feature"> <h3 class="bold uppercase"> <span class="rectangle"></span> Author </h3> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Caroline Klapp" data-src="https://www.wbrc.com/resizer/b81Q3F9aH0FPp2c1WOhSxDRwmyw=/1400x0/s3.amazonaws.com/arc-authors/raycom/0b268fdd-2106-46a5-b216-9a054dae3aed.png" src="https://www.wbrc.com/resizer/LMRB-ZirjVCHB3nZpJuDYglSCOA=/0x10/s3.amazonaws.com/arc-authors/raycom/0b268fdd-2106-46a5-b216-9a054dae3aed.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/caroline-klapp/"> <h3 class="promo-header">Caroline Klapp</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Reporter</h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/CarolineTVNews" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://www.facebook.com/carolinewaff48/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:cklapp@waff.com?subject=Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Caroline joined the WAFF 48 News team in November 2019 as a reporter and multimedia journalist. She graduated from Texas Christian University with a degree in journalism in December 2016. After graduation she moved to northern Michigan to work for 9&10 News. Caroline is excited for a break from the snow she had in Michigan.</p> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Margo Gray" data-src="https://www.wbrc.com/resizer/bi2LcOS_dIrNjoW7k43Ob6TE_qg=/1400x0/s3.amazonaws.com/arc-authors/raycom/5447fa0a-7a14-464c-9523-21cd685e8684.png" src="https://www.wbrc.com/resizer/46Mf4WLhcJZvVREja576LOn1I94=/0x10/s3.amazonaws.com/arc-authors/raycom/5447fa0a-7a14-464c-9523-21cd685e8684.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/margo-gray/"> <h3 class="promo-header">Margo Gray</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">4PM & 10PM News Anchor</h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://twitter.com/MargoGray48" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" href="https://www.facebook.com/MargoGrayWAFF48/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:mgray@waff.com?subject=Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Margo Gray has served the Tennessee Valley for WAFF 48 since September 2009.</p> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="Wade Smith" data-src="https://www.wbrc.com/resizer/HGuZk3YqvB6FPIgcEGwr4Pb47sw=/1400x0/s3.amazonaws.com/arc-authors/raycom/0ab36c97-7878-4994-aaf6-e64b469ae3dd.png" src="https://www.wbrc.com/resizer/UvwkYHYk42Si_RfK8Uz22lNPOWg=/0x10/s3.amazonaws.com/arc-authors/raycom/0ab36c97-7878-4994-aaf6-e64b469ae3dd.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/wade-smith/"> <h3 class="promo-header">Wade Smith</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Digital Content Manager</h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:wade.smith@waff.com?subject=Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">Wade is a graduate of the University of Alabama. He started his news career in radio in Atlanta, GA. Before coming to WAFF 48, he spent over six years reporting news in Birmingham.</p> </div> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12 height-full"> <div class="card skin"> <div class="card-media"> <div class="flex-grid"> <div class="flex-container-row "> <div class="flex spaced card-media flex-container-column justify-center flex-reverse spaced-left spaced-md"> <div data-type="image" class="author-bio author-bio-image card"> <figure class=""> <div class=" img-container aspect-ratio-3x2"> <img class="b-lazy width-full img-container" alt="William McLain" data-src="https://www.wbrc.com/resizer/_ffo3qD8eAxI4HoomwqlX30mnko=/1400x0/s3.amazonaws.com/arc-authors/raycom/6335b919-9cef-42f8-96e6-21b1c2526829.png" src="https://www.wbrc.com/resizer/k1NjuM38t5LPkcOs4WFf7duzpkw=/0x10/s3.amazonaws.com/arc-authors/raycom/6335b919-9cef-42f8-96e6-21b1c2526829.png"/> </div> </figure> </div> </div> <div class="flex-2 flex-container-column justify-center"> <a class="spaced spaced-sm spaced-bottom" href="/authors/william-mclain/"> <h3 class="promo-header">William McLain</h3> </a> <h4 class="spaced spaced-xs spaced-bottom font-normal color-grey-dark">Assistant News Director</h4> <h4 class="hidden font-normal color-grey-dark"></h4> <span class="buttonbar buttonbar app-bar-share flex-container-grid width-full spaced spaced-sm spaced-top font-lg"> <a class="button button-icon button-icon-hover-accent social-icon button-lg button-dark" aria-label="Contact via email" href="mailto:wmclain@waff.com?subject=Rock%20and%20roll%20legend%20Little%20Richard%20remembered%2C%20laid%20to%20rest%20Wednesday%20in%20Huntsville&body=" role="button" rel="noopener noreferrer" data-arctrack="socialFollowEm"> <i class="far fa-envelope"></i> </a> </span> </div> </div> <div class="flex-container-row justify-space-between "> <div class="author-bio author-bio-description collection collection-cards"> <div data-type="text" class="card collection-item"> <div class="card-content card-article"> <p class="font-md ">William is a graduate of Auburn University. He started his career at WSFA in Montgomery before making the move to the Rocket City.</p> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-mailchimp-signup" id="fxwHfN1Xz0ktKr"> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c0NRdx1Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fhr3sb2Xz0ktKr"> <div class="flex-feature "> <h3 class="bold"><span class="rectangle"></span> RECENT CONTENT</h3> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-133768" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2020/05/20/montgomery-hospitals-very-critical-point-with-covid-mayor-says/"> <img class="width-full " alt="Montgomery hospitals at ‘very critical point’ with COVID-19, mayor says" src="https://www.wbrc.com/resizer/WxTBEnJFmvtQsAa1xuR2eKVg0V8=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/FZOXFQF73JA2BJWWNR6N44GAMU.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/20/montgomery-hospitals-very-critical-point-with-covid-mayor-says/"> Montgomery hospitals at ‘very critical point’ with COVID-19, mayor says</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">“Right now, if you are from Montgomery and you need an ICU bed, you are in trouble,” the mayor said.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WSFA Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center"> <div class="width-full spaced card-media"> <figure class=""> <div class="width-full img-container aspect-ratio-2x1"> <a href="/2020/05/20/farmers-families-program-benefit-jefferson-co-families/"> <img class="width-full " alt="‘Farmers to Families’ program to benefit Jefferson Co. families" src="https://www.wbrc.com/resizer/DP-72pkuugUylnEzMQbvDazxYR0=/1200x600/cloudfront-us-east-1.images.arcpublishing.com/raycom/DGZTHKDR2RA5BF2NL4Y4UXLG5A.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/20/farmers-families-program-benefit-jefferson-co-families/"> ‘Farmers to Families’ program to benefit Jefferson Co. families</a></h4> <div class="spaced color-grey-dark font-md" data-pb-field="custom.blurbText_" data-pb-url-field="custom.blurbUrl_" data-pb-field-type="text" data-pb-placeholder="#">Residents will receive a 20 pound box of fresh fruit and vegetables.</div> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row "> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WBRC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f09JMK9Xz0ktKr"> <div id="ad1314-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad1314" class="arcad ad-300x250"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad1314",slotName:"wbrc/web/news/top-story",adType:"cube",dimensions:"[[[300, 250]], [[300, 250]], [[300, 250]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"XYSCHHIYRZCCBEHLCP6KPPPKZI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="col pb-layout-item pb-chain pb-c-single-chain full" id="c008fu9Xz0ktKr"> <div class="flex-grid"> <section class="col desktop-12 tablet-12 mobile-12"> <div class="flex-grid"> <div class="wrapper clearfix col full pb-feature pb-layout-item pb-f-homepage-story-feed" id="fmrOMh1Xz0ktKr"> <div class="flex-feature "> <div class="flex-feature height-full flex-grid api-returned-stories" id="load-more-wrapper-7638" data-content-service="content-feed"> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/18/black-jacket-symphony-presents-concerts-car/"> <img class="width-full " alt="Black Jacket Symphony presents ‘Concerts from the Car’, lowers some ticket prices" src="https://www.wbrc.com/resizer/11eHNJERKhQQQjRMmgp92HO3aTI=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/5EQFBCMZ7RAN7LZW3BEZPKRRJY.JPG"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/18/black-jacket-symphony-presents-concerts-car/"> Black Jacket Symphony presents ‘Concerts from the Car’, lowers some ticket prices</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WBRC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 1h at 1:27 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/20/taste-fair-coming-leeds/"> <img class="width-full " alt="Taste of the Fair coming to Leeds" src="https://www.wbrc.com/resizer/74ORXgw7kxkZdiWDlBLhg6Oep2U=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/S5KXPTADFBBODJSD3AAF64WT6A.jpg"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/20/taste-fair-coming-leeds/"> Taste of the Fair coming to Leeds</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WBRC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 1h at 1:08 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/03/16/confirmed-cases-coronavirus-alabama-skyrockets-during-weekend/"> <img class="width-full " alt="ADPH: 517 Alabamians have died from COVID-19 as more than 12K test positive" src="https://www.wbrc.com/resizer/NPkIigA38FTQAv6x5wzcVgXQOxg=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/7XGVDKXU5RBJLHAMZ6UI7LFEVQ.png"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/03/16/confirmed-cases-coronavirus-alabama-skyrockets-during-weekend/"> ADPH: 517 Alabamians have died from COVID-19 as more than 12K test positive</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WBRC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 1h at 1:01 PM </div> </div> </div> </div> </div> </div> </div> <div class="col desktop-12 tablet-6 mobile-12"> <div class="card skin"> <div class="card-media width-full"> <div class="align-items-center flex-container-row justify-space-between"> <div class="width-full spaced card-media flex-reverse spaced-left spaced-lg flex"> <figure class=""> <div class="width-full img-container aspect-ratio-4x3"> <a href="/2020/05/20/buffalo-wild-wings-will-re-open-dining-rooms-friday/"> <img class="width-full " alt="Buffalo Wild Wings will re-open dining rooms on Friday" src="https://www.wbrc.com/resizer/dGcBlfYRWnhkkOPk8xxVPH9HVOE=/1200x900/cloudfront-us-east-1.images.arcpublishing.com/raycom/XUB3VKJTT5BKVCUTJ3STWD5ZE4.png"> </a> </div> </figure> </div> <div class="card card-article-mobile-only width-full flex-container-column flex-2"> <h4 class="promo-header spaced spaced-xs spaced-bottom spaced-top font-normal"><a class="unstyled-link " href="/2020/05/20/buffalo-wild-wings-will-re-open-dining-rooms-friday/"> Buffalo Wild Wings will re-open dining rooms on Friday</a></h4> <div class="byline-timestamp-container flex-container-column flex-desktop-row spaced spaced-top spaced-xs align-items-start"> <div class="byline-wrapper flex-container-row hidden"> <span class="byline">By&nbsp;</span> <h3 class="byline bold"> <span>WBRC Staff</span> </h3> <span class="spaced spaced-right spaced-md"></span> </div> <div class="font-sm color-grey byline-wrapper flex-container-row "> Published 2h at 12:26 PM </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </div> </section> </div> </div> <div class="pb-container"> </div> </aside> <div id="recirc" class="col desktop-12 tablet-12 mobile-12"> </div> </div> <section id="bottom" class="col desktop-12 tablet-12 mobile-12"> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-ads-arcads" id="f0XShVkXz0ktKr"> <div id="ad471-sticky" class="flex-container-column "> <div class="flex-container-row justify-center "> <div id="ad471" class="arcad ad-728x90 zindex-med"></div> <script>window.serviceCallbacks.push(function(){window.helpers.includeAd(arcAds,{id:"ad471",slotName:"wbrc/web/news/top-story",adType:"flex-leaderboard",dimensions:"[[[970, 250], [970, 90], [728, 90]], [[728, 90]], [[320, 50]]]",targeting:{position:{"as":"posn"},position_type:"",pt:"a",cid:"XYSCHHIYRZCCBEHLCP6KPPPKZI"},display:"all",sizemap:{breakpoints:"[ [1024, 0], [768, 0], [319, 0] ]",refresh:true},bidding:{prebid:{enabled:true,timeout:1E3,bids:[{bidder:"appnexus",params:{placementId:14567590}}]}}},{lazyload:true})});</script> </div> </div> </div> <div class="wrapper clearfix full pb-feature pb-layout-item pb-f-global-footer" id="fU2oFF1Xz0ktKr"> <footer class="card card-dark"> <div class="container"> <div class="container spaced spaced-sm spaced-left"> <div class="flex flex-container-column flex-tablet-row flex-desktop-row width-full color-white"> <div class="spaced spaced-right spaced-bottom spaced-xl"> <div class="logo-container flex flex-container-row align-items-center justify-left"> <a aria-label="Visit homepage" href="https://www.wbrc.com"> <div class="logo logo-large logo-footer"></div> </a> </div> </div> <div class="spaced spaced-right spaced-xl footer-mission"> <p class="spaced spaced-bottom spaced-xs"> 1720 Valley View Drive<br/>Birmingham, AL 35209<br/>(205) 322-6666 </p> <a class="call-to-action uppercase color-white" href="http://www.wbrc.com/about-us/">Contact Us <i class="fa fa-caret-right" aria-hidden="true"></i></a> <div class="spaced spaced-top spaced-xl hidden-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wbrc" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@wbrc.com" class="color-white">publicfile@wbrc.com<br/>(205) 583-4343</a></li> <li><a href="http://webpubcontent.raycommedia.com/wbrc/PDF/EEO_Report_WBRC_2017-2018.pdf" class="color-white">EEO Report</a></li> <li><a href="https://www.wbrc.com/2019/05/14/closed-captioning-wbrc-fox-news/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WBRC Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="spaced spaced-top spaced-xl hidden-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WBRCnews" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/WBRCnews/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> <div class="spaced spaced-right spaced-xl visible-lg"> <ul class="list-unstyled call-to-action uppercase"> <li><a href="http://publicfiles.fcc.gov/tv-profile/wbrc" class="color-white">FCC Public File</a></li> <li><a href="mailto:publicfile@wbrc.com" class="color-white">publicfile@wbrc.com<br/>(205) 583-4343</a></li> <li><a href="http://webpubcontent.raycommedia.com/wbrc/PDF/EEO_Report_WBRC_2017-2018.pdf" class="color-white">EEO Report</a></li> <li><a href="https://www.wbrc.com/2019/05/14/closed-captioning-wbrc-fox-news/" class="color-white">Closed Captioning</a></li> <li><a href="https://gray.tv/careers#currentopenings" class="color-white">WBRC Careers</a></li> <li><a href="/privacy-policy/" class="color-white">Privacy Policy</a></li> <li><a href="/terms-of-service/" class="color-white">Terms of Service</a></li> </ul> </div> <div class="visible-lg"> <span class="buttonbar app-bar-share flex-container-grid width-full text-align-right"> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://twitter.com/WBRCnews" role="button" aria-label="Visit Twitter" target="_blank" rel="noopener noreferrer"> <i class="fab fa-twitter "></i> </a> <a class="button button-icon button-icon-hover-accent button-lg footer-social-icon" href="https://www.facebook.com/WBRCnews/" role="button" aria-label="Visit Facebook" target="_blank" rel="noopener noreferrer"> <i class="fab fa-facebook-square "></i> </a> </span> </div> </div> </div> </div> </footer> </div> <div class="pb-container"> </div> </section> </div> <script async="async" src="https://widgets.outbrain.com/outbrain.js"></script> <script async src='/pb/gr/p/default/rHJ9vP1Xz0ktKr/render.js?v=90'></script> <script>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</script> <script>window.banditoEnv={TIMEOUT:1500,PERF_API:"https://bandito-events.perso.aws.arc.pub/api/save-perf",TESTS_API:"https://bandito.perso.aws.arc.pub/api/variants",EVENTS_API:"https://bandito-events.perso.aws.arc.pub/api/save-event"};if(window["pageBuilder"]&&window["pageBuilder"]["initVariants"])window.pageBuilder.initVariants({IS_ADMIN:false,TIMEOUT:window.banditoEnv.TIMEOUT,PERF_API:window.banditoEnv.PERF_API,TESTS_API:window.banditoEnv.TESTS_API,EVENTS_API:window.banditoEnv.EVENTS_API});</script> <script async src="/pb/resources/dist/96cfbfc61ff908bdad44/rm/rm-index96cfbfc61ff908bdad44.js"></script>